Fresh Water Tank Gauge Inop.

Discussion in 'Electrical Stuff' started by 2000SR380, Dec 29, 2015.

  1. speakrdude

    speakrdude Well-Known Member

    Feb 21, 2009
    Northwest Arkansas
    2002 Sea Ray 340 DA
    Raymarine C80 Tri Data
    twin 6.2 MX MPI
    Awh, you guys...
     
  2. Matt Michels

    Matt Michels Member

    49
    Apr 12, 2019
    Centreville, VA
    2006 Sea Ray 380DA
    Yanmar Diesel
    Hi Jim.
    So, I took the water sensor out today. I did notice the at the waste sensor was having isues as well. I pumped the tank out, and it showed empty. Affter using it a few times, it now just says "power" . not sure if this is the same issue. Would you mind cheching out that sensor panel as well?
     
  3. Mike sandor

    Mike sandor Active Member

    171
    Jul 28, 2017
    Eau Claire, Wisconsin
    2007 320 Sundancer
    Twin 496. Bravo 3
    2018 3500 Chevy, Loadmaster trailer
    Raymarine Axiom, Quantum 2
    496 Mercruiser/Bravo III drives
    Last year, mine worked fine. Now, The waste level indicator only shows power and empty. Needless to say I just ordered another inline filter as it now needs replacing. I notice there are three sending units in the tank. Assuming that if using a meter and they all show open, the problem is with the board.
     
  4. speakrdude

    speakrdude Well-Known Member

    Feb 21, 2009
    Northwest Arkansas
    2002 Sea Ray 340 DA
    Raymarine C80 Tri Data
    twin 6.2 MX MPI
    Ive not repaired a waste panel. These “sensors” unless a float, is a simple continuity probe at different levels. The simple way to test is short ground (blk) to one color at a time, (Not Red) while watching the panel.
    If it still doesnt work, send it to me! If it does work, check or temporarily wire a good ground to the tank sensor.
     
    Matt Michels likes this.
  5. Matt Michels

    Matt Michels Member

    49
    Apr 12, 2019
    Centreville, VA
    2006 Sea Ray 380DA
    Yanmar Diesel
    Thanks Jim. I'll check it out today. The waste sensor is right next to the water, so if I cant figure it out I send that one over as well. It should only take a second to pull.
     
  6. speakrdude

    speakrdude Well-Known Member

    Feb 21, 2009
    Northwest Arkansas
    2002 Sea Ray 340 DA
    Raymarine C80 Tri Data
    twin 6.2 MX MPI
    Matt, rec’d both of yours today.
    Replaced the 4 components on the fresh water board. Tested, 100%.
    Holding tank led array works fine the way it is.
    Test you +12v at the connection and ground on both ends! Will send back tomorrow.
    Enjoy!
    Jim Crews
     
    Matt Michels and carterchapman like this.
  7. Matt Michels

    Matt Michels Member

    49
    Apr 12, 2019
    Centreville, VA
    2006 Sea Ray 380DA
    Yanmar Diesel
    Thanks Jim. I appreciate your help!!!
     
  8. speakrdude

    speakrdude Well-Known Member

    Feb 21, 2009
    Northwest Arkansas
    2002 Sea Ray 340 DA
    Raymarine C80 Tri Data
    twin 6.2 MX MPI
    Have you installed it yet?
     
  9. Matt Michels

    Matt Michels Member

    49
    Apr 12, 2019
    Centreville, VA
    2006 Sea Ray 380DA
    Yanmar Diesel
    Hey Jim. Thanks again for fixing those. I did get them but haven’t had a chance to install yet. Trying to do that over the weekend.
     
  10. speakrdude

    speakrdude Well-Known Member

    Feb 21, 2009
    Northwest Arkansas
    2002 Sea Ray 340 DA
    Raymarine C80 Tri Data
    twin 6.2 MX MPI
    Let me know if you need any help!
    479-530-6666
    Jim
     
    Matt Michels likes this.
  11. skydance

    skydance New Member

    3
    Jul 1, 2019
    express cruiser 370, 1997
    yanmar 6lpa-stp
    Hello,
    i owned searay express curiser 370. and same problem in my led indicator..but i am so far from your location. i'm in south korea. so, Would you inform me of the transistor spec. i am going to buy it in korea market.
    thanks in advance

    s.c. Hwnag
     
  12. speakrdude

    speakrdude Well-Known Member

    Feb 21, 2009
    Northwest Arkansas
    2002 Sea Ray 340 DA
    Raymarine C80 Tri Data
    twin 6.2 MX MPI
    (4) 2n 3906
     
  13. skydance

    skydance New Member

    3
    Jul 1, 2019
    express cruiser 370, 1997
    yanmar 6lpa-stp
    Thanks. i will try to fix the problem and share the results.
     
  14. Matt Michels

    Matt Michels Member

    49
    Apr 12, 2019
    Centreville, VA
    2006 Sea Ray 380DA
    Yanmar Diesel
    Hey Jim.

    I was able to install the water sensor and it works great. Thanks again!!!
     
    Chris-380 likes this.
  15. Chris-380

    Chris-380 Well-Known Member

    Jan 20, 2019
    Pontoon Beach IL
    2000 380 Sundancer
    7.4L Horizon w/V drives
  16. speakrdude

    speakrdude Well-Known Member

    Feb 21, 2009
    Northwest Arkansas
    2002 Sea Ray 340 DA
    Raymarine C80 Tri Data
    twin 6.2 MX MPI
    Looks right!
    If your in the states,
    Message me your address and I’ll put 4 in the mail for you, n/c.
    Jim
     
    Chris-380 likes this.
  17. sbw1

    sbw1 Well-Known Member

    Oct 10, 2006
    West Michigan
    This is listed in my signature
    This is listed in my signature
    You guys should stop messing with these electronic boondoggles and install a Tank Tender. It is old tech that has been around for years and never stops working. IMG_4230.JPG
     
  18. CaptRonn

    CaptRonn Well-Known Member

    May 25, 2016
    on a large body of water
    1999 Sea Ray 400 Sedan Bridge
    Convert fuel into noise
    The fix that speakrdude (Jim) has developed works. He sent me 4 transistors, I installed and it works like new. The fix has worked for others as well. (Again, thank you Jim!)

    Seeing that you aren't a SR owner and this situation really doesn't apply to you, why are you trying to dissuade others from a relatively simple fix?
     
    Chris-380 likes this.
  19. sbw1

    sbw1 Well-Known Member

    Oct 10, 2006
    West Michigan
    This is listed in my signature
    This is listed in my signature
    IMG_4230.JPG
    For the simple reason that Tiara used the same vendor for tank indicators as SR did when I bought the boat new in 2004. It stopped working the first week I owned the boat. Tiara's warranty policy then was to offer three fixes of this gauge. After that we were on our own. The selling dealing suggested Tank Tender as a fix. I exhausted my warranty fixes in 5 weeks so went with the Tank Tender in 2004. It has worked flawlessly for 15 years. Pump outs cost $20 a pop in GH so the thing has paid for itself many times over and there has been no need to take things apart and mail them to somebody for repair. So this is not really a SR issue. It is much more about sharing solutions to common problems that deminsh the joy of boating. The next time you have to fix your indicator, consider a solution that gets at the root cause of the failure as opposed to continuing to use this poorly designed gauge. One Tank Tender also monitors fresh water tanks and your diesel fuel as well. One monitor does all three functions.
    BTW, Jim's willingness to fix these gauges is admirable. I do wonder about how many more years he will continiest to be so genrous with his time.
    Does this answer your question?
     
  20. CaptRonn

    CaptRonn Well-Known Member

    May 25, 2016
    on a large body of water
    1999 Sea Ray 400 Sedan Bridge
    Convert fuel into noise
    Nope.

    All I see is someone who wants to direct others as what to do with their personal property.

    I could really care less about your former Tiara and what you did with it, it has zero relevance to this thread.

    The fix we now have is working, and it's an easy fix. I suspect this fix will work for many years to come.

    Again, kudos to Jim (speakrdude) for offering a working and easy solution.
     

Share This Page

Show Sidebar