Hello, new member and owner

Discussion in 'Who's Who' started by Sea Otter, Jun 10, 2018.

  1. Sea Otter

    Sea Otter New Member

    1
    Jun 10, 2018
    Cape Coral, FL
    260 Sundancer 2002
    Mercruiser Horizon w/Bravo III
    Hello all. Just bought a 2002 Sundancer and brought it home today. I got to run her from her old home in Largo, FL to her new home in Cape Coral, FL. It was a nice ride and a good chance to get to know her. I spent the day, cleaning and checking things out and have uncovered a few rapairs that will be needed. I am hoping that I can find the information I will need here. I am looking forward to lots of good family time on this boat.

    Take care everyone.
     
    Little Ducky likes this.
  2. LG111

    LG111 Active Member

    433
    Jan 4, 2015
    NW
    410
    8.1
    congratulation!

    we want details! size, engines, electronics, add on's and wish lists!
     
  3. Ezsteps

    Ezsteps Active Member PLATINUM Sponsor

    444
    Nov 14, 2015
    Lake St. Clair-- Michigan
    1999 400 Sundancer, YL310 Zodiac
    7.4 Mercuisers Horizons 380 hp ea., 9.9 hp Mercury
    Congrats and Welcome Aboard. ....
     
  4. Happy Dayz

    Happy Dayz Active Member

    386
    Jun 26, 2017
    Sarasota, FL
    '06 260 Sundancer, 6.2, BIII, Kohler 5kw
    79' classic Kona Family Cruiser jet boat..
    6.2 w/ BIII, 502 w/ Berkekley
    sweet! love our 260! and yes, pics needed!
     
  5. Boater420

    Boater420 Well-Known Member

    Mar 11, 2015
    Clearwater, FL
    '97 330 Sundancer
    V-Drives
    Westerbeke 4.5BCG
    Twin Merc 454's
    Welcome to CSR!
     
  6. Jeff Delbuono

    Jeff Delbuono Active Member

    124
    Jun 11, 2018
    Edison new jersey
    1998 sea ray 290 sundancer
    5.0 efi
    I just purchased a 1998 290 sundancer with twin 5.0 efi and alpha 1 gen 2 drives. Love it. Sat for 7 years and took 7 weeks of cleaning and fixing things. Prob now is both motors run great. Take out on water and they will not go past 3000 rpm. Any thoughts
     
  7. gdavis67

    gdavis67 Active Member

    123
    Mar 1, 2017
    Saugatuck, MI
    1990 390ec
    Twin 454 Mercruiser T 340 with Hurth drives
    Both engines do the same thing? Start with the simple things if you have not already done them. Sitting for seven years can definitely lead to fuel issues and that would be the first item I would look at if they idle great, but suffer under load. Replace all fuel filters, also make sure to check the port where the fuel line enters the carb, there are often small filters in the inlet that people forget about. If you have filters at the carb inlet, be sure to replace with stainless mesh filters, not paper ones. When changing the fuel filters, pour the fuel from the filter into a clear container. After a few minutes the fuel and water that might be in the tank/filter will seperate. If you see water in the fuel sample you will need to drain the tanks and possibly have them treated. It depends on how bad the water contamination is. Disconnect the vent lines on your fuel tanks and blow carb cleaner in them and then follow up with a blast of compressed air. Spiders love the vent lines and if they get plugged you will suffer under load. If that doesn't do it, move to the carbs. A good tear down and cleaning of all ports may be needed if the boat sat with fuel in the carbs for seven years. Also check all vacuum hoses on each motor. Again, time will deteriorate rubber lines and vacuum leaks and a big culprit to running under load issues.
     
  8. Jeff Delbuono

    Jeff Delbuono Active Member

    124
    Jun 11, 2018
    Edison new jersey
    1998 sea ray 290 sundancer
    5.0 efi
    Thanks. Well that didnt work. Changed all filters. Checked pick ups and vent line and all good. Ran 1 motor to an external fuel tank ans 1 motor to boat fuel tank. Same damb thing. They are 1998 5.0 efi motors. Changed fuel pumps, fuel injextors. Coils, ingnition moduels, valve sencors, nock sensors, cap rotor, fuel filters. I do not have a merc scanner to scan computer. Its an opel 10 pin. Any clue where tp go next
     
  9. Jeff Delbuono

    Jeff Delbuono Active Member

    124
    Jun 11, 2018
    Edison new jersey
    1998 sea ray 290 sundancer
    5.0 efi
    Both motors do same thing together and independant. Is there a mode it can be in or a sencor i am missing that controls both motors
     
  10. KevinC

    KevinC Well-Known Member

    Feb 25, 2011
    Long Island, NY
    2004 340 Sundancer
    1988 Proline Center Console - 90hp Mariner/Mercury
    1969 Boston Whaler
    Twin 8.1 V-drives
    Welcome @Sea Otter ! Thats a great great boat and a forum thread specially for those models. Lots good reading. I owned a 2003 260DA so I know first hand how helpful the information available here is.

    -Kevin
     
  11. KevinC

    KevinC Well-Known Member

    Feb 25, 2011
    Long Island, NY
    2004 340 Sundancer
    1988 Proline Center Console - 90hp Mariner/Mercury
    1969 Boston Whaler
    Twin 8.1 V-drives
    Welcome @Jeff Delbuono !

    Again start with the basics but are you getting any alarms or beeps? They may be indicative of the issue. Not sure if the ECM on the 1998s would put the engines into "limp" or "guardian" mode if a alarm is present like it would in an overheat situation.

    One other note Jeff - you might get more responses if you create your own thread for this as this might get lost here.

    -Kevin
     
  12. Jeff Delbuono

    Jeff Delbuono Active Member

    124
    Jun 11, 2018
    Edison new jersey
    1998 sea ray 290 sundancer
    5.0 efi
    No alarm..and i tried to bring this to the group. Dont know how. When i clixked on start conversation it said i had to pick a person. So i put in all and that didnt work. Put in sea ray and got you.
     
  13. Todd320

    Todd320 Active Member

    540
    Jul 21, 2016
    St. Petersburg, FL
    2007 Sea Ray 320DA
    Twin V-drive 5.7L 350 Horizon
    Lick on forums, the find the engine gas forum, click create Thread, the title should be something like TWIN 5.0 1988 EFI ONLY REACH 3k rpm, or something similar. That will get the engine people on it.
     
  14. Todd320

    Todd320 Active Member

    540
    Jul 21, 2016
    St. Petersburg, FL
    2007 Sea Ray 320DA
    Twin V-drive 5.7L 350 Horizon
    CLICK! Not Lick! Licking doesn’t help. At all.
     
  15. Afman82

    Afman82 New Member

    2
    May 2, 2018
    Maryland
    Sea Ray 2007 SLX
    496ci MAG DTS w/Brave III Drive
    I have a question: When I turn the ignition key on my 496ci Mag, 8.1L (255 hours) it turns slow for the first rotation and starts. I've checked the wiring for corrosion and replaced one of the batteries (both are new). Before I jump to conclusions and have the starter replaces is there anything I'm missing? Not sure if this is something that anyone else has run into. Looking for some help?
     
  16. Zim

    Zim Active Member

    132
    Jan 16, 2018
    2012 Sea ray sundancer 310
    Twin merc
    Congrats and welcome. The ride must have been amazing. Good luck with repairs and enjoy the summer
     

Share This Page

Show Sidebar