Suspect power steering pump

Discussion in 'Gas Engines/Drives/Transmissions/Props' started by macnewbie, Sep 10, 2019 at 10:58 PM.

  1. macnewbie

    macnewbie New Member

    5
    Dec 2, 2016
    Seattle
    2017 SLX 310
    Twin 300HP 6.2L MPI w/ Axius, Bravo III
    Hello everyone -

    We own a 2017 310 SLX - twin 300HP 6.2L MPI engines with ~125 hours. A few days ago, we smelled burned rubber followed by rising starboard engine temperature. I shut the engine down and limped home on the other one.

    The culprit was a snapped serpentine belt, so I ordered a couple spares and threw a new one on and started the engine. Almost immediately I smelled burned rubber again and realized that the belt is not turning and thus the crankshaft pulley is tearing up the belt.

    Checking all pulleys I now know that the one that is not allowing the belt to turn is the power steering pump - not sure if it's shot, seized or what. I don't know what happened or how to troubleshoot next.

    Any ideas where to go next besides calling my dealer for a dockside service call?

    Thanks in advance
     
  2. scoflaw

    scoflaw Well-Known Member

    Aug 10, 2011
    cape cod mass, cape coral fl
    1999 Powerquest legend 260 sx
    502 mpi Bravo 1
    Rare indeed. You need a new pump
     
  3. Zim

    Zim Active Member

    178
    Jan 16, 2018
    2012 Sea ray sundancer 310
    Twin merc
    Rare, but agree a new pump is required.
     
  4. Bt Doctur

    Bt Doctur Well-Known Member

    Aug 21, 2010
    New Jersey
    Ex SRV 240 Weekender twin
    in between
    get a Saginaw pump and change out your innards and reuse the steel shell and your pressure reliefe
     
  5. Korkie

    Korkie Active Member SILVER Sponsor

    543
    Feb 2, 2016
    Leonardtown, MD Potomac River / Chesapeake Bay
    340 Sundancer 2006, Garmin 7612, xHD Radome
    Merc 496 Mags
    Bravo III Drives
    Only a 2017 - Warranty?
     

Share This Page

Show Sidebar