System Monitor

Discussion in 'General Maintenance/Repair Questions' started by BobFino, Sep 10, 2019 at 9:08 PM.

  1. BobFino

    BobFino Member

    53
    Aug 26, 2010
    Virginia Beach
    Sea Ray 550 Sedan Bridge 2005.
    MAN 900
    Twin Disc MG-5114
    My system monitor is giving me all sorts of strange messages. After doing research and some testing it looks like it could be the coax cable. Can somebody tell me where the coax cable connects to from the System Monitor? Thank you

    Sea Ray System Monitor.jpg
     
  2. superwa

    superwa Active Member GOLD Sponsor

    186
    Jul 27, 2013
    Rhode Island
    2001 Sea Ray Sundancer 380
    Mercruiser horizon 8.1S
    Mine it goes to the system monitor module that’s below the helm behind the fuses. It does get loose overtime, you may just have to cut a bit and reattached at the screen
     
  3. tc410

    tc410 Active Member PLATINUM Sponsor

    907
    Oct 9, 2006
    Charlevoix, MI/Jupiter, FL
    2005 550DB
    MAN CRM-900
    You have a “black-box” in the engine space. It is mounted on the port half of the forward bulkhead, right above the vacuum generators for the heads. It’s about 6”x8” and has a multi-pin connector and the coax on the right side of the box.

    You can try to run a direct coax from bridge to computer through the engine access hatch for a test. If that fixes it, then fish it through. If it doesn’t, you probably need a new display. I just went through the same issues and ended up buying a new display for around $825.
     
  4. BobFino

    BobFino Member

    53
    Aug 26, 2010
    Virginia Beach
    Sea Ray 550 Sedan Bridge 2005.
    MAN 900
    Twin Disc MG-5114
    Thank you, I will check the connections by running the cable through the hatch for a test.
     

Share This Page

Show Sidebar