Partner Sites:  www.BOEmarine.com | www.CBangler.com | www.BandofBoaters.com

Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 38
  1. #21
    Join Date
    Jul 2010
    Location
    Maple Valley, WA
    Boat
    Sea Ray
    Details
    Current: 1998 370 Express Cruiser Sold:1988 230 Weekender
    Engine(s)
    Twin Cat 3116T
    Posts
    92

    Re: Official 370 Express Cruiser Thread (1997-2000)

    Do you have a switch both on the transom and inside the cabin? That's my setup - each switch is a 3 way, the lights can be turned on/off from either location. I don't have another switch at the helm, and none of mine of the indicator lights that you mention, so not sure about that. If your indicator light luminated before, it could be another fuse / breaker somewhere that's popped, but I'm not sure where that would be located. I'll take a look when I'm next at my boat to confirm. For now just see if you can look in the same location I mentioned before to see if a breaker needs reset.

    Kevin

    1998 370 Express Cruiser "Seafari"
    Moored in Parkshore Marina, Seattle, WA

  2. #22
    Join Date
    Mar 2016
    Location
    Chicago
    Boat
    Sea Ray
    Details
    1997 Sea Ray 370 Express Cruiser
    Engine(s)
    Twin 7.4L Mercruiser MPI
    Posts
    38

    Re: Official 370 Express Cruiser Thread (1997-2000)

    Quote Originally Posted by GnrlPatton View Post
    Do you have a switch both on the transom and inside the cabin? That's my setup - each switch is a 3 way, the lights can be turned on/off from either location. I don't have another switch at the helm, and none of mine of the indicator lights that you mention, so not sure about that. If your indicator light luminated before, it could be another fuse / breaker somewhere that's popped, but I'm not sure where that would be located. I'll take a look when I'm next at my boat to confirm. For now just see if you can look in the same location I mentioned before to see if a breaker needs reset.

    Kevin
    This was indeed the issue... when I flipped the switch in the cabin first, the transom switch turned the cockpit lights on. I actually thought that switch turned on the florescent light in the cabin ceiling to turn on.

    That said, is there a different switch for that florescent light? I replaced the lightbulb but still can't it to turn on. If it's not one thing, it's another :)

    Thanks again Kevin!!

  3. #23
    Join Date
    Mar 2016
    Location
    Chicago
    Boat
    Sea Ray
    Details
    1997 Sea Ray 370 Express Cruiser
    Engine(s)
    Twin 7.4L Mercruiser MPI
    Posts
    38

    Re: Official 370 Express Cruiser Thread (1997-2000)

    Has anyone replaced there Autohelm with something that swaps simply? I think the depth reader on the transducer has finally bit the dust on mine and looking to replace. I'm nearly certain the boat will have to be hauled out so probably an end/beginning of season project.

    Thanks!

  4. #24
    Join Date
    Jul 2010
    Location
    Maple Valley, WA
    Boat
    Sea Ray
    Details
    Current: 1998 370 Express Cruiser Sold:1988 230 Weekender
    Engine(s)
    Twin Cat 3116T
    Posts
    92

    Re: Official 370 Express Cruiser Thread (1997-2000)

    I think there may be only 2 of us in this boat, but I'll ask it here anyway. I'm looking to get my bait well (not the live well) hooked up. The previous owner had disconnected everything, so I'm trying to sort through it, hoping that someone else has either an Amberjack or EC that can describe how their boats are plumbed.

    I have the through hull for the raw water supply - that is working fine.
    I have the overflow drain that goes to the drain out of the transom - I think it's working fine though I haven't been able to test it because I don't want to fill the well up until the next one is working:
    The bottom drain is hooked into a T, one line from the bait well, one line from the live well (that one I've capped off), then they both feed into a pump mounted onto the transom, with another line going to a through hull on the bottom of the hull, right next to the raw water inlet.

    That last one, the pump is activated and I hear it trying to pull water through, but the level in the well doesn't go down. I initially saw a single bubble come up when I pulled the plug, but nothing after that. I'm pretty sure that the plumbing makes sense the way I've hooked it up, and the very rough drawing in the manual seems to indicate that is correct as well, but I can't figure it out. None of the hoses are blocked, kinked, etc. and the drain through hull is open. I'm hoping someone else with the AJ/EC has theirs hooked up and can describe (or better yet, take a photo or two!) their setup.

    Thanks in advance!
    Kevin

    1998 370 Express Cruiser "Seafari"
    Moored in Parkshore Marina, Seattle, WA

  5. #25
    Join Date
    Jan 2014
    Location
    Key West & Naples, Fl.
    Boat
    SeaRay
    Details
    2004 500 Sundancer
    Engine(s)
    QSM11's 660hp
    Posts
    84

    Re: Official 370 Express Cruiser Thread (1997-2000)

    I had a 2000 37 EC with the same setup. The pump that drains both the fish locker and bait well is not a regular pump setup. It's a suction type of pump and when on it pulses rather than runs like a regular water pump. Your pump may not be working or the thru hull valve(s) are shut off. If it is working and your thru hull valve are open on the transom, it should be working. There should be two maybe three valves that need to be open. When it pumps you will hear it pulse and the water level in the bait well or fish locker will seem to pulse with it. That's how you know it's working, plus the obvious, the water goes out! Good luck.

    Bow Tie

  6. #26
    Join Date
    Jul 2010
    Location
    Maple Valley, WA
    Boat
    Sea Ray
    Details
    Current: 1998 370 Express Cruiser Sold:1988 230 Weekender
    Engine(s)
    Twin Cat 3116T
    Posts
    92

    Re: Official 370 Express Cruiser Thread (1997-2000)

    Thanks Bow Tie. I have opened all the seacocks that appear to be connected to the system, and I do hear the pump working when I flip the switch. The first time I flipped the switch, I saw an air bubble come up from the drain, but the water level didn't change. It seems like the pump isn't primed (if it even needs to be), or it's just not getting suction. I haven't spent a ton of time working on it yet, but will next week. I'll see if I can figure it out.

    Thanks for the info!
    Kevin

    1998 370 Express Cruiser "Seafari"
    Moored in Parkshore Marina, Seattle, WA

  7. #27
    Join Date
    Jan 2014
    Location
    Key West & Naples, Fl.
    Boat
    SeaRay
    Details
    2004 500 Sundancer
    Engine(s)
    QSM11's 660hp
    Posts
    84

    Re: Official 370 Express Cruiser Thread (1997-2000)

    If you can hear the pump running (pulsing) try disconnecting the hose on the intake side of the pump, if the pump is working you will feel it when you put your hand on the intake barb. If the pump has suction try blowing out the drain inside the bait well before you put the hose back on by putting a garden hose on it. Your pump will empty the fish locker and the bait well at the same time until both are empty. You can also try pulling the hose on discharge side of the pump in order to make sure your valve is open. You may also have a bad seal in the pump, if there is no suction when you put your hand on the intake that would be your problem. One more question, did you try the fish locker? Or are you just working on the bait well? If the fish well works and your bait well does not, you have a clog, kink, or a valve that is not open. Good luck, I'm sure it's a simple fix.

    Bow Tie
    Last edited by Bow Tie; 08-04-2016 at 07:40 PM.

  8. #28
    Join Date
    Jul 2010
    Location
    Maple Valley, WA
    Boat
    Sea Ray
    Details
    Current: 1998 370 Express Cruiser Sold:1988 230 Weekender
    Engine(s)
    Twin Cat 3116T
    Posts
    92

    Re: Official 370 Express Cruiser Thread (1997-2000)

    Thanks for the additional info. I'll give that a shot next week. I'm only working on the bait well, the hose for the live well drain is disconnected and capped. I first wondered if that may be the problem, but it doesn't make sense that it would be. I'll check the pump out and make sure we're getting suction there. I agree, it's got to be something simple. I hope.

    1998 370 Express Cruiser "Seafari"
    Moored in Parkshore Marina, Seattle, WA

  9. #29
    Join Date
    Jul 2009
    Location
    new jersey
    Boat
    searay
    Details
    37 express cruz
    Engine(s)
    3126 cats
    Posts
    28

    Re: Official 370 Express Cruiser Thread (1997-2000)

    I have a 37 express and i absolutely love it, i changed the fridge, all lights to led cockpit and salon. all new hatch visors, reupholstered the birth. re striped the hull, pulled out the cockpit freezer and made a storage locker, upgraded stereo, redid the canvas, upgraded all the electronics, i removed the rear lounge seat, thinking of selling that, also i am looking for a factory hardtop if anyone knows of one around, thank you any questiond feel free to ask i know these boats pretty good , i had a 33epress sold it and bought a 37 with diesels, just kinda finished it up this summer, but like every one else always something to do on a boat

  10. #30
    Join Date
    Jul 2010
    Location
    Maple Valley, WA
    Boat
    Sea Ray
    Details
    Current: 1998 370 Express Cruiser Sold:1988 230 Weekender
    Engine(s)
    Twin Cat 3116T
    Posts
    92

    Re: Official 370 Express Cruiser Thread (1997-2000)

    Quote Originally Posted by aquaholic View Post
    I have a 37 express and i absolutely love it, i changed the fridge, all lights to led cockpit and salon. all new hatch visors, reupholstered the birth. re striped the hull, pulled out the cockpit freezer and made a storage locker, upgraded stereo, redid the canvas, upgraded all the electronics, i removed the rear lounge seat, thinking of selling that, also i am looking for a factory hardtop if anyone knows of one around, thank you any questiond feel free to ask i know these boats pretty good , i had a 33epress sold it and bought a 37 with diesels, just kinda finished it up this summer, but like every one else always something to do on a boat
    Did you change the galley fridge? Were you having issues with the old one? I'm noticing that mine apparently doesn't like the cold weather as it doesn't maintain freezing temp in the freezer part during the winter. It happened last winter and this one, during the summer it was fine. I'm wondering if it's time to look at replacing it or if that's normal.

    Welcome to the thread, glad to see another 370EC owner here!

    1998 370 Express Cruiser "Seafari"
    Moored in Parkshore Marina, Seattle, WA

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •