Partner Sites:  www.BOEmarine.com | www.CBangler.com | www.BandofBoaters.com

Results 1 to 6 of 6

Thread: 220 SRV forum

  1. #1
    Join Date
    Sep 2015
    Location
    Michigan
    Boat
    Sea Ray
    Details
    74 SRV220. nearly mint condition, garage kept and covered
    Engine(s)
    188 Mercruiser
    Posts
    16

    220 SRV forum

    Mine is a 74 220SRV and I think this is the most beautiful boat ever built.

  2. #2
    Join Date
    Sep 2015
    Location
    Michigan
    Boat
    Sea Ray
    Details
    74 SRV220. nearly mint condition, garage kept and covered
    Engine(s)
    188 Mercruiser
    Posts
    16

    Re: 220 SRV forum

    boat was near mint, a garage queen. PO blew the 302. considered many options, but finally found and installed a similar 188 Mercruiser engine. nearly done, weekend project. runs great. should be a fun summer.

  3. #3
    Join Date
    Sep 2014
    Location
    BC
    Boat
    Sea Ray and Alicraft
    Details
    1981 24.5' SR custom hardtop 1984 18' Valco sled 1984 20' Alicraft- sold
    Engine(s)
    5.7 260 Merc/ Bravo 2 Evanrude 115/80 jet
    Posts
    142

    Re: 220 SRV forum

    Any pics?

  4. #4
    Join Date
    Sep 2015
    Location
    Michigan
    Boat
    Sea Ray
    Details
    74 SRV220. nearly mint condition, garage kept and covered
    Engine(s)
    188 Mercruiser
    Posts
    16

    Re: 220 SRV forum


  5. #5
    Join Date
    Sep 2014
    Location
    BC
    Boat
    Sea Ray and Alicraft
    Details
    1981 24.5' SR custom hardtop 1984 18' Valco sled 1984 20' Alicraft- sold
    Engine(s)
    5.7 260 Merc/ Bravo 2 Evanrude 115/80 jet
    Posts
    142

    Re: 220 SRV forum

    Very nice! Back on the water where she should be..

  6. #6
    Join Date
    Sep 2015
    Location
    Michigan
    Boat
    Sea Ray
    Details
    74 SRV220. nearly mint condition, garage kept and covered
    Engine(s)
    188 Mercruiser
    Posts
    16

    Re: 220 SRV forum

    well I don't have a big budget for this job, so it took a while. Its ready for its first test run in the water. I have checked everything 3 times. I set the shifter, and throttle by the book, its all tight. Changed unit oil, topped off power tilt, and trim tabs oils, found a blown fuse in trim tabs, and they work perfect. I have to mount the marine radio, the stereo, and the hummingbird, but I know the water where I will test it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •