School Me On Navman Tracker 5500

BleednBlue

Member
Jul 22, 2015
163
Lake Of The Ozarks
Boat Info
270 SLX
Engines
Merc. 496 MAG Bravo III
First off, I have read the owners manual and spent several hours this weekend playing with the unit. I also do ALL my boating at the Lake Of The Ozarks.

That said, what is this unit buying me? I don't get it. All my gauges work (smartcraft and analog). What does this unit tell me that my other gauges won't (besides latitude and longitude).

I hope I am missing something because I really want the Navman Tracker 5500 to be a useful tool and not just a glorified GPS unit.

Thanks for your time,
Rich
 
It's a moderately fancy GPS. I replaced mine with a Lowrance Elite-5 HDI and I'm very happy with it.
 
Thanks for the reply and link. Is the 5500 now compatible with Smartcraft system? I ask because there were menu items in the system set up that referenced Smartcraft but none of the displays seem to be getting data.
 
You have to buy the gateway which is no longer manufactured. My gateway went out. It was nice while it lasted. The gateway brings the data over. It was not included with the original installation from Sea Ray.
 
You have to buy the gateway which is no longer manufactured. My gateway went out. It was nice while it lasted. The gateway brings the data over. It was not included with the original installation from Sea Ray.

I get it now.... half a$$ job by Sea Ray.

skolbe, thanks for your help.
 
I may have othe gate in my garage. If proper one pay shipping it's yours.
 
First, I would like to thank Banagy (Bill) for sending me the items in the picture below. Second, the title says Tracker 5500 but I actually have 5505 model.


Obviously the Navico Smartcraft gateway (red circle) plugs into the back of the 5505 unit. However, the Junction Box (green circle) is confusing me. It seems I probably already have a junction box onboard because I have the Smartcraft tach?!?! If yes, is the junction box located behind the dash?


 
Little frustrated here. Plugged in the NAVICO Smartcraft Gateway (picture above) and the lights lit up correctly. NAV light blinking, CAN light blinking, power light constant on. However, the Navman Tracker 5505 unit is not displaying any Smartcraft data. So after a closer look, the gateway clearly says NAVICO. Should the correct gateway say NAVMAN? Oh, and yes I did go into the Tracker 5505 settings and enabled Smartcraft. Any help is appreciated...thanks!
 
It's working! I'm a ding dong...failed to connect the terminator to the unused port on the junction box. Plugged in yellow terminator then like magic the Tracker 5505 was displaying engine data.
 
I have that unit and interface on my boat. It is not that great of a GPS really - the interface is clunky.
However, it does display smartcraft error messages and has saved me from breaking out the computer and interface to read an error code in the past.
 
The first thing I checked was error code history. There is one event without any details. No code, no date, nothing. Can codes be cleared or history deleted? Could not find a menu item for clearing or deleting.
 

Forum statistics

Threads
113,071
Messages
1,425,393
Members
61,002
Latest member
stacimchale
Back
Top