Searay dies chirps lost engine comm what to do? Help

Discussion in 'Sport Boats' started by MICHAEL TIGGES, Jun 16, 2022.

  1. MICHAEL TIGGES

    MICHAEL TIGGES New Member

    9
    May 1, 2010
    TENNESSEE
    240 SEA RAY SUNDECK 2006
    350 MAG W/BRAVO III DRIVE
    Hello everyone
    I recently had quite a bit of work done on my Seary sundeck 2006 350 merc And now it is posting a lost engine comm and the engine dies after a chirps when idling or when dropping back down into idle mode
    The tech who is certified has checked all the connections we have new batteries but continues to reproduce the problem it should be noted that the transducer and the distributor were replaced the oil changed the water control unit changed in the boat was cleaned inside and out I did notice water in the battery base which indicates they must’ve really used quite a bit of Water
    Everything started after the engine was worked on and tuned up and the batteries were replaced after I brought it home and itdied with loss engine comm when I put it back on the lake
    Anyway I cannot figure this out we’ve checked tach and the transducer in the grounds typically it will idle for about 40 seconds and then throw the lost engine comm Also check the fuses all good
     
  2. OllieC

    OllieC Well-Known Member SILVER Sponsor

    Mar 11, 2013
    MinniSoCold
    Sara Belle
    2005 Weekender 215
    Mercruiser 5.0 mpi, Bravo III
    Is it stuttering or shutting down, then chirping like when you start the motor, turning the fuel pump on? I had an issue last year where I thought the chirp was a warning but what it was doing was stalling then going into restart mode by chirping and kicking on the fuel pump. Turned out it was the crankshaft sensor that failed.
     
    Phil S likes this.
  3. Arminius

    Arminius Active Member

    826
    Oct 30, 2019
    Seattle
    Bowrider 200 Select, 2003
    5.0L MPI, 260 hp w/Alpha 1 Drive
    Check the codes. An intermittent crankshaft position sensor on a Mercedes drove me nuts.
     
  4. MICHAEL TIGGES

    MICHAEL TIGGES New Member

    9
    May 1, 2010
    TENNESSEE
    240 SEA RAY SUNDECK 2006
    350 MAG W/BRAVO III DRIVE
    Doesnt stutter, just throws lost engine comm and dies, it seems to start after engine warms up and runs for 10 minutes then after warmed up it does it starts fine then after 45 seconds it loses engine comm and engine dies, will start right back up, recently changed out water pump and impeller, transducer, distributor oil change , water control unit, new batteries, have checked grounds and all connections checked and reseated.
     
  5. MICHAEL TIGGES

    MICHAEL TIGGES New Member

    9
    May 1, 2010
    TENNESSEE
    240 SEA RAY SUNDECK 2006
    350 MAG W/BRAVO III DRIVE
    Thats interesting, where is it located ?? as we had a bunch of work done on in that area....

    Doesnt stutter, just throws lost engine comm and dies, it seems to start after engine warms up and runs for 10 minutes then after warmed up it does it starts fine then after 45 seconds it loses engine comm and engine dies, will start right back up, recently changed out water pump and impeller, transducer, distributor oil change , water control unit, new batteries, have checked grounds and all connections checked and reseated.
     
  6. Little Ducky

    Little Ducky Well-Known Member

    Jun 5, 2017
    Dickson, TN / Chattanooga, TN
    1998 290 Sundancer
    Twin EFI 5.0L w/Alphas
    Kohler 4kW
    Just a guess.

    I would look at your ECM.

    It's to bad you don't have twins where you could swap ECM and see if the situation follows.
     
  7. Arminius

    Arminius Active Member

    826
    Oct 30, 2019
    Seattle
    Bowrider 200 Select, 2003
    5.0L MPI, 260 hp w/Alpha 1 Drive
    Dealers have a $600 code reader. That is always where you start with a modern engine. Your car has a OBD2 port under the dash where standard and vehicle specific codes are read. My Android phone does it with a blue toothed $25 gadget. No such available for Mercruiser.
     
  8. rkeats

    rkeats Member

    35
    Aug 6, 2009
    Cincinnati, OH
    2005 240 SD
    350 Mag, BIII
    Hey Michael, did you ever get this figured out? I am having a similar issue. Boat dies usually restarts, somethings no power to gages and no crank. Lost engine comms is the usually code. Dealer no help with code reader.
     

Share This Page

Show Sidebar