Bravo 3 leaking antifreeze

Discussion in 'General Maintenance/Repair Questions' started by Coz, Nov 29, 2020.

  1. Coz

    Coz Member

    285
    Oct 9, 2018
    2008 Sundancer 310
    Merc Mag 350 DTS w/Bravo III
    After winterizing and running antifreeze through, one of my drives leaks antifreeze through the intake ports. Is that cause for concern?
     
  2. Bt Doctur

    Bt Doctur Well-Known Member

    Aug 21, 2010
    New Jersey
    Ex SRV 240 Weekender twin
    in between
    nope,as long as you drained everything first , just some in the hose draining out
     
  3. Espos4

    Espos4 Well-Known Member

    Jan 1, 2017
    Long Island NY
    2007 240 Sundeck
    350 MAG Bravo 3 W/DTS
    I would think that’s a sign that one or more impeller vanes are missing or worn.
     
  4. Coz

    Coz Member

    285
    Oct 9, 2018
    2008 Sundancer 310
    Merc Mag 350 DTS w/Bravo III
    That's what I was afraid of. It's been dripping for 6 weeks. Guess it's time I learned how to change out impellers.
     
  5. Lazy Daze

    Lazy Daze Well-Known Member TECHNICAL Contributor GOLD Sponsor

    Apr 21, 2009
    PA
    Various
    Various
    I wouldn't worry too much about it. B3 impellers fit very tight, but liquid does make it past - albeit very slowly. Also sometimes depends on just how the impeller "sits" when it stops compared to the inlet opening. If it's been a while since you replaced it, though, go ahead and do and chalk it up to "PM". But it's pretty normal to see dripping.
     

Share This Page

Show Sidebar