1. Please join your fellow forum members on our new Facebook Group. https://www.facebook.com/groups/247355990036949

Sundeck 230 select

Discussion in 'Electronics Q&A' started by Brandon1995, Oct 20, 2020.

  1. Brandon1995

    Brandon1995 New Member

    9
    Jun 25, 2020
    Cleveland Ohio
    2008 sundeck 230
    350 mercruiser
    Boat ran fine all year. The boat sat for about 3/4 weeks. Went to go winterize the boat, can’t get the engine to turn or trim to work . Everything else works (blower ,pump, dashboard, trim tabs). System is reading a system fault. Power relay not working properly. We tried jumping the batteries, pushing time, living in the great state of Ohio lol.
     
  2. Brandon1995

    Brandon1995 New Member

    9
    Jun 25, 2020
    Cleveland Ohio
    2008 sundeck 230
    350 mercruiser
    Any help on if this is maybe one of the barriers is shot and causing a failure ? Or we have some wiring issues . Fuses are good checked those
     
  3. Espos4

    Espos4 Well-Known Member

    Jan 1, 2017
    Long Island NY
    2007 240 Sundeck
    350 MAG Bravo 3 W/DTS
    Did you check the kill switch near the throttle lever?
     
  4. Brandon1995

    Brandon1995 New Member

    9
    Jun 25, 2020
    Cleveland Ohio
    2008 sundeck 230
    350 mercruiser
    Yes kill switch is up - on run. You should be able to move the trim with the key not even on.
     
  5. Lazy Daze

    Lazy Daze Well-Known Member TECHNICAL Contributor GOLD Sponsor

    Apr 21, 2009
    PA
    Various
    Various
    What "power relay" are you referring to?

    "Can't get the engine to turn"... meaning it won't even attempt to do anything, right? Does the starter click? How did you jump the batteries? With a known good battery? What's the V at each battery? Did you load test them? Check for power at both sides of starter fuse.
     
  6. Brandon1995

    Brandon1995 New Member

    9
    Jun 25, 2020
    Cleveland Ohio
    2008 sundeck 230
    350 mercruiser
    Dave,

    You are correct starter does not even click . We did not trouble shoot the batteries . System is saying low voltage. We just replaced both batteries at the beginning of the year so didn’t think this had something to do with it. We used a Ford super duty truck to try and jump the batteries
     
  7. Brandon1995

    Brandon1995 New Member

    9
    Jun 25, 2020
    Cleveland Ohio
    2008 sundeck 230
    350 mercruiser
    Not sure what power relay the system is talking about . The dashboard is the one telling me the power relay is not working properly
     
  8. Espos4

    Espos4 Well-Known Member

    Jan 1, 2017
    Long Island NY
    2007 240 Sundeck
    350 MAG Bravo 3 W/DTS
    If it’s saying low voltage, your batteries somehow drained over the 3-4 weeks you were away or you’ve got dirty/loose connections somewhere causing the chaos.
     
  9. Lazy Daze

    Lazy Daze Well-Known Member TECHNICAL Contributor GOLD Sponsor

    Apr 21, 2009
    PA
    Various
    Various
    Check battery V directly at each battery. Charge and load test if needed. For good measure, check the starter fuse.
     

Share This Page

Show Sidebar