Drive-stbd Tvm: low hydrolic oil level

Hi can you share me what seal or part did they changed in your pod drive? I'm having same issue same as you experienced
 

Attachments

  • 20230708_200450.jpg
    20230708_200450.jpg
    138.3 KB · Views: 64
  • 20230708_193845.jpg
    20230708_193845.jpg
    141.2 KB · Views: 64
Thanks for the reply, it’s scheduled to go into the dealer tomorrow. Their thoughts are that the power steering actuator seal has failed. Seems to be not that uncommon, I have 3rd gen pods (JH). This will involve hauling the boat out, removing the lower pod and maybe a little more. I’m having them do both sides as a precaution in hopes that it keeps me on the water and out of the shop. I’ll let you know after they dig in.


Please hope you have picture what did they changed in your pod drive I'm having same issue with your pod
 

Attachments

  • 20230708_193845.jpg
    20230708_193845.jpg
    141.2 KB · Views: 52
  • 20230708_200450.jpg
    20230708_200450.jpg
    138.3 KB · Views: 52
Thanks for the reply shaps I'm having port side pods but i recommend both pods will change if the problem steering actuator seal
 

Attachments

  • 20230709_092441.jpg
    20230709_092441.jpg
    199.2 KB · Views: 60
Hi @altour, apologies, but I'm nnot sure what you are asking
 
Hi can you share me what seal or part did they changed in your pod drive? I'm having same issue same as you experienced


had one of my power steering actuator seals fail and needed to be replaced. hard to tell from your picture but it looks like fluid has come out of the top of the monitor? if so that would be my first guess. if you replace one, do yourself a favor and replace both. i also had all of my hydraulic lines and rings change as a precaution.
 

Forum statistics

Threads
112,726
Messages
1,417,634
Members
60,774
Latest member
Baf923792
Back
Top