New Citimarine AC Is this OK?

dtfeld

Water Contrails
GOLD Sponsor
Jun 5, 2016
5,553
Milton, GA
Boat Info
410 Sundancer
2001
12" Axiom and 9" Axiom+ MFD
Engines
Cat 3126 V-Drives
Ordered new Citimarine CTM CT-16 AC unit. 2 day shipping I was pretty pumped. Box arrive looked like it had survived the trip OK.

However, when I went to unbox, I notice that the main pipe leading to the top of the compressor seems to be crushed (see picture). Anybody have a picture of what its supposed to be? I assume it supposed to be a full flow pipe at that location.

Citimarine online chat not very helpful...

IMG-0069.jpg
 
Well I will give them cuddos on the customer service. The rep I was chatting with online actually picked up the phone, and called me. Its on it way back to Citimarine for a replacement. 10+ on communication and quick service.
 
I don't like it one bit. It may work fine now but could be a problem in the future, likely post warranty but maybe not and then they might say you damaged. However it was damaged may have compromised the solder/welds at either end of the damage.
 
Already shipped back. They will send a new unit back once they receive back. I'm on vacation, so that will be fine...not going to miss anything.
 
We bought a Webasto from them last week, great service.

So far they have stepped up. Originally, I asked if they could ship UPS, but they said that UPS damaged their AC units in shipping. I went with the standard and free Fed Ex.

I think the issue is how they have the units packed...there is no protection on that pipe, so if it gets turned over on shipment, it will bend/smash that pipe. I think its more of a packaging issue. They need to add some support around that pipe, then I don't think it would matter. That pipe is the one damaged, and it right were the packaging stops.

A1F65646-5660-47BF-93C4-9C71B5EF997A.jpeg


However, still looking forward to getting it installed with the new touch screen thermostat. No more 3 fingered double secret handshake to change setting on the old SMX II. However, still have to work out how to mount the remote...requires a hole to be cut. I prefer a mounting plate of some kind. Otherwise I'll run out of places to cut holes.
 
Last edited:
We have had luck with trophy shops making panel for us. Same problem, all these different brands have different size control panels.
 
I was very happy with Citimarine’s service through the sales process and post sales support. Great company. My CT-10 model is installed in the stateroom and is working great. Tough install in such a tight space! Glad it is done!
 
I was very happy with Citimarine’s service through the sales process and post sales support. Great company. My CT-10 model is installed in the stateroom and is working great. Tough install in such a tight space! Glad it is done!

Fortunately Citimarine told me to purchase the adapter cable, which made the existing SMX II panel plug and play.
 
I can tell you not happy with Marinaire right now…..my masterAC unit went down with low Freon this weekend… I ripped it out and they said they would pay for shipping and labor that wasn’t part of the warranty…. Installed July last year…..I was expecting 10 years trouble free….. really not happy
 
I can tell you not happy with Marinaire right now…..my masterAC unit went down with low Freon this weekend… I ripped it out and they said they would pay for shipping and labor that wasn’t part of the warranty…. Installed July last year…..I was expecting 10 years trouble free….. really not happy
Sorry to hear. Citi mentioned this exact scenario going on with Marinaire lately. I discounted it at the time as sales talking points…maybe not.

on the flip side, with some gas and a hose set off Amazon, you should be able to field service and get yourself a few months. But…1 year??? Yeah, I’d be pissed too.

It will be interesting to see if the Citi unit holds up, because once I added in the new thermostat, the domestic units were not too much more $$$
 
I can tell you not happy with Marinaire right now…..my masterAC unit went down with low Freon this weekend… I ripped it out and they said they would pay for shipping and labor that wasn’t part of the warranty…. Installed July last year…..I was expecting 10 years trouble free….. really not happy

Damn, do you leave it running full time or on dehumidifier mode? Keep us posted...
 
I left my main unit running...may have to rethink that
 
Just had a new Dometic 12,000 btu unit installed yesterday. Got 12 years out of the old one.
 
My salon unit bit the dust after 18 years and I was hesitant to go with Dometic again since the new units get pretty bad reviews. In the end, stuck with them and went with a 27k BTU that's an absolute beast and seems built very well. I have a feeling that most of the complaints are for the smaller turbo units.
 

Forum statistics

Threads
113,118
Messages
1,426,523
Members
61,035
Latest member
Lukerney
Back
Top