The official "Stray Current II" thread. '07 260DA

It looked damaged when I took the picture but after wiping it with a rag, it was just a sludge buildup at the bottom. I’m not really sure what caused it to fail. I popped the old seal out today, but I didn’t see any noticeable grooving or telltale signs of failure The sling radiates out from the crankshaft though, so that is definitely it

Of course, once I get it all put back together with a new exhaust manifold, the PTO seal is going to leak…

If you delete it I will also.
 
View attachment 154925View attachment 154926
My motor mount kit came today for the generator pan, and I swung by the Upholstery shop to check out a sample of my new interior.

I think the tan to tie into the dashboard and the existing tan accents, as well as the royal navy piping will really tie it all together.
Best upholstery shop dress code I’ve seen yet. I have a feeling you wouldn’t have it any other way. Hahaha
It looks good, should be nice when you finish. By the time you’re done you best keep her, she’ll be damn near new.
 
Best upholstery shop dress code I’ve seen yet. I have a feeling you wouldn’t have it any other way. Hahaha
It looks good, should be nice when you finish. By the time you’re done you best keep her, she’ll be damn near new.
That’s funny, I didn’t even realize she was in the picture when I posted it. But yeah when they came out to do the initial estimate and every time I’ve been in the shop to pick material or drop stuff off that’s the dress code in there. Florida is kind of cool like that.

As far as keeping the boat, who knows. I’ve been hemming and hawing on that for the last three years. I’m just in the rabbit hole at this point wondering where the bottom is. It’s also not lost on me that I put a lot more hours on than most, and will have more wear and tear. I’ve put over 125 on since May and I feel like I’m not using it as much as I would like.

I had wound up resealing my adapter plate for my remote oil filter that was leaking a few pages back. I washed the entire engine with hot water and degreaser to remove all the oil film. I’ve got a terrible feeling in the pit of my stomach though that it may have also been a weep from the rear main that is going to continue to get worse. Though it’s possible it’s not, some of the film was a little farther away from that leaking adapter plate then I reasonably think it should have been.

DON’T EVER LOOK AT THE NUMBERS!
With everything that it has been needy with this year I’ve saved way short of my target for the year, I do not like that.

I did have it surveyed before I put the engine back in in April. There were no areas of elevated moisture anywhere along the hull, transom or deck. Everything seems solid and watertight structurally since I resealed everything, so there is that is as a positive

And since I decided not to delete what @techmitch quoted, I’m going to go ahead and replace the PTO seal on the generator while it is sitting on my workbench at “stand up straight and work like a human” height. I’m gonna meg out the windings as well and replace the injector that’s been sitting in my cabinet for the last four years.

I have to rip it all apart to change that corroded manifold anyway. Since we have no plans of overnighting and it’s on my bench, I really don’t have any sense of urgency about it. I’m gonna take my time with the generator and not let it bother me. The fridge runs off batteries for day trips
 
IMG_3284.jpeg
IMG_3283.jpeg
Not too bad for rewrapping 16 year old foam and backings. Unfortunately, some of the back rest cushions went a little obtuse from their angle sitting in the shop. I’m going to have one of them remade I think
 
Losing $8000 on resale value, a visual representation
IMG_3390.jpeg


Go figure I am going to miss the first Christmas parade that I am in the water in Florida because I have no way to power Christmas lights
 
Losing $8000 on resale value, a visual representation View attachment 155633

Go figure I am going to miss the first Christmas parade that I am in the water in Florida because I have no way to power Christmas lights

Why not use a small inverter for the light while running - with the low load of LEDs you may get by. No reason to miss out on the holiday fun.

-Kevin
 
IMG_6490.jpeg
IMG_3702.jpeg
IMG_3703.jpeg


Took a nice little spin for NYD. It’s definitely a bit chilly without her second heartbeat to push the heat pump and cockpit space heater :p

I should probably stop sandbagging and being lazy about fixing little satan. No real rush as I still need my new manifold
 
On that seal - If the armature outer bearing or flex plate is not 100% then that rear crankshaft bearing must take all of the weight or vibration of the armature and will sag and fail the seal. Those little Kawi engines don't have robust crank bearings and for sure not designed to carry much of a bending load.
What I'd do is get a dial indicator on the engine crankshaft at the armature interface and run it out so see if it's bent or the rear crank bearing has issues. The only other thing that can cause a seal to leak is if the crankcase pressure went high - PCV or crankcase vent is plugged up. Definitely check the generator's end bearing for wear/failure - replace it anyway since you are down that far......
My 14kw Onan service manual says to check the rear bearing at 5000 hours but it doesn't say what/how to check. It's a standard ball bearing that if I'm in that far to check it then it gets replaced. My generator has about 6000 hours on it....
 
Slow progress between bizarro world rainy season and waiting on parts. I got the bare cast iron exhaust manifold primed, and I have the heat exchanger in its’ final teal. Hoping to get the manifold in its final hot pink tomorrow.

The electrical connection doghouse is going to be painted fluorescent yellow with a bright purple top to match the fuel pump. That needs a bit of sanding and feathering before paint.

Still waiting on quite a few parts like hoses and O-rings. I have all the new seals and gaskets
IMG_3977.jpeg
IMG_3980.jpeg


It can’t be evil anymore if it’s all soft and colorful, right?
 
Before I go too much farther with paint and prep, I’m going to resistance test all of my windings and hit the rotor and stator with a megohmmeter. This will verify the electrical integrity of the windings and vacuum impregnated insulation. Not that it really matters because this far down the rabbit hole and buying at dealer cost if I need new windings, I will buy new windings. But I will be sharing the specification tables for the 5.0 and 7.3 ECD because there is not a whole lot of information readily available on a Google search.

Also found a digital copy of the service manual and parts manual for the set. This also covers the 5E and the 50 Hz variants of all three. The actual Kawasaki engine service manual is like unobtanium.

I had a link that somebody sent me to a drive file, but it seems like it is no longer available.
IMG_3981.jpeg


@highslice that is your gps sitting on my bench whenever you shoot me that label
 
Deep down, when I pulled the genset I knew I was going to have a major failure in either the engine or drive. When I signed for the upholstery I knew it was a foregone conclusion and would definitely happen.

I just limped home with a knock from what I assume is the outdrive. Came off plane and had a rhythmic thump that I hear and feel between 600 and 1800 rpm.

Seems to be in sync with engine speed in gear only and doesn’t matter what angle of steering or trim. I’m assuming it’s the lower unit but when I turn the props at the dock, it seems normal.

Debating a total repower or just cutting my losses and selling as is. I’m tired
 
Deep down, when I pulled the genset I knew I was going to have a major failure in either the engine or drive. When I signed for the upholstery I knew it was a foregone conclusion and would definitely happen.

I just limped home with a knock from what I assume is the outdrive. Came off plane and had a rhythmic thump that I hear and feel between 600 and 1800 rpm.

Seems to be in sync with engine speed in gear only and doesn’t matter what angle of steering or trim. I’m assuming it’s the lower unit but when I turn the props at the dock, it seems normal.

Debating a total repower or just cutting my losses and selling as is. I’m tired
Solve the problem first …. Then decide…. Hell it’s the only thing you havnt replaced
 
Solve the problem first …. Then decide…. He’ll it’s the only thing you havnt replaced

It’s definitely the drive, standing on the swim platform with high idling at 800 it is clearly from the lower.

This drive has some bad juju!
 
It’s definitely the drive, standing on the swim platform with high idling at 800 it is clearly from the lower.

This drive has some bad juju!
Well it’s got a lot of black paint on it…. So it’s goth….. and we know bad juju is goth …. I’m surprised you want to get rid of it….. but you do you
 

Forum statistics

Threads
112,729
Messages
1,417,781
Members
60,773
Latest member
Thirty9sportfish
Back
Top