Official 370 Sundancer thread

You won’t find that in a Sea Ray part number. If you are comfortable working with voltage and current, there is the meter, and a pickup that measures the current. Doubtful if if meter is bad. Did it quit on you, or was it inoperable since you have owned the boat?
 
You won’t find that in a Sea Ray part number. If you are comfortable working with voltage and current, there is the meter, and a pickup that measures the current. Doubtful if if meter is bad. Did it quit on you, or was it inoperable since you have owned the boat?

Ahh ok. Been inoperable since I owned it. I honestly haven’t taken the panel off to see what’s behind there yet. I’ll get to it this weekend and see if the pickup needs replaced
 
Ahh ok. Been inoperable since I owned it. I honestly haven’t taken the panel off to see what’s behind there yet. I’ll get to it this weekend and see if the pickup needs replaced

Where did you buy the yellow ladder for your dog to us on your swim platform?
 
Anyone have an electric version of the 1998 370DA Owners Manual?

Seems odd that the SR site doesn't have much for the 370DA.
 
Looking at pictures of your "Beach House 11." Living in a home with a dock out front!!!! Has always been my dream.

But that in CA would cost at lest 10 to 20 times what it costs in FL.
 
Looking at pictures of your "Beach House 11." Living in a home with a dock out front!!!! Has always been my dream.

But that in CA would cost at lest 10 to 20 times what it costs in FL.
more like 50x. Lucked out with these. My father in law when we bought the first one.....
ME: Well I don't have much of a view.
HIM: You gotta boat?
ME: Yeah, right there.
HIM You gotta view.....
 
New to this thread / forum so I hope I am in the right place. The water pump in our 1997 370 SUNDANCER finally told us it was time for replacement. I ordered a Jabsco 3195-4022-3A ParMax3 as the specs were the closest to what was there. After getting some fittings to join the Pex to the pump the install went well (no leaks). Initially the pump work fine but it is now stuttering just before it shuts off after bringing the pressure up. Any hints would be appreciated with thanks in advance.
 
New to this thread / forum so I hope I am in the right place. The water pump in our 1997 370 SUNDANCER finally told us it was time for replacement. I ordered a Jabsco 3195-4022-3A ParMax3 as the specs were the closest to what was there. After getting some fittings to join the Pex to the pump the install went well (no leaks). Initially the pump work fine but it is now stuttering just before it shuts off after bringing the pressure up. Any hints would be appreciated with thanks in advance.
Can you video what you are describing? Don’t think it’s an issue. Mine slows and “styuters” a few times before it stops. Always has from my 20 years of ownership.
 
Can you video what you are describing? Don’t think it’s an issue. Mine slows and “styuters” a few times before it stops. Always has from my 20 years of ownership.
The way you are describing it is exactly what it is doing. The pump slows down and stutters for a few seconds before shutting off. I will do the video though the next time I am there. Thanks
 
Can you video what you are describing? Don’t think it’s an issue. Mine slows and “styuters” a few times before it stops. Always has from my 20 years of ownership.
We were out for the day yesterday and dropped the hook for a few hours. I noticed when we used the the water system that the pump didn’t stutter. When we got back and I plugged in to shore power and the charger came on the pump did a few stutters before shutting off. My theory is that when the pump is seeing a slighty higher voltage it precipitates this issue.
 
When I purchased this boat I noticed that along with the sync gauge there was also a Sturdy engine sync installed. The PO told me that had never used it in the short time he had owned the boat. I finally got curious enough to try it out. Thanks to some great posts on this forum I got good instructions on how to operate the system. There is a bit of lag but the once the slave engine gets settled the boat ran great. Question, is there any maintenance I should be attending for this device as there are mechanical parts involved.
 
JJ, didn’t have much time, but I did swing by E dock yesterday. No one around, but I believe you are 2nd in from the basin on the side facing the gas dock. Maybe on a future trip we can catch up.
 
I need to replace most of these resetable circuit breakers, but I'm struggling to find a good straight-swap replacement here is AUS. Has anyone replaced these, and if so what did you source?
20220716_215304.jpg
 
Hello all,
There is a switch at my helm marked “ELECT” that does not seem to operate anything. It does not illuminate when switched either. Is this just a spare?
Thanks… learning one button at a time!!
 

Forum statistics

Threads
112,684
Messages
1,416,459
Members
60,740
Latest member
Jack Paver
Back
Top